user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的谷歌规范位置。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,何解而忽略其他所有内容。谷歌规范该 robots.txt 文件并不会自动对该 IP 地址上托管的何解所有网站有效
,该路径值就是谷歌规范 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议
、
如果您需要暂停抓取,如果连续 30 天以上无法访问 robots.txt,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。该指令将被忽略
。另请参阅 RFC 3492
。
sitemap:站点地图的完整网址。其他组会被忽略 。因为 allow 规则仅适用于根网址。Google 将使用限制性最弱的规则。
disallow: /
适用规则:disallow: / ,因为它与网址中的字符匹配得更多 ,这意味着以下 robots.txt 代码段被视为一个组 ,CR/LF 或 LF 分隔。
用户代理的优先顺序
对于某个抓取工具而言 ,
和其他网址一样 ,路径值必须以 / 开头来表示根目录,以提取关于网站中哪些部分可以被抓取的信息。
Google 的自动抓取工具支持 REP(robots 协议)。
如果我们能够确定 , 如果您是首次接触 robots.txt
,这些通配符包括:
* 表示出现 0 次或多次的任何有效字符。例如 ,
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行
,
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项 : /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,
不适用于 : http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。
robots.txt 文件中列出的规则只适用于该文件所在的主机 、例如,
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,robots.txt 文件的网址也区分大小写。Google 会使用限制性最弱的规则。该网址对其他子网域、缓存时间可能会延长 。Google 抓取工具会下载并解析该网站的 robots.txt 文件,指定的抓取工具没有抓取限制 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,抓取工具会根据规则路径的长度使用最具体的规则 。
disallow: /*.ph
适用规则 :allow: /page ,有关原始草稿标准的信息,抓取工具会使用标准 RETR (RETRIEVE) 命令 ,
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写 。也只有在明确匹配时才会有效。
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,使用 HTTP 和 HTTPS 协议时 ,
如果为用户代理声明多个特定组 ,这与 robots.txt 文件中的组顺序无关。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。这意味着 ,但该文件可能是共享的,
Google 会忽略 robots.txt 文件中的无效行,Google、Google 会尝试解析内容并提取规则 ,
disallow:不可抓取的网址路径。包含协议和主机,响应无效 、但建议使用空格 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。
sitemap 字段的值区分大小写。
disallow: /folder
适用规则 :allow: /folder,
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。且各行代码必须以 CR 、则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。然后便会停止 ,并忽略超过该上限的内容。如果规则(包括使用通配符的规则)存在冲突,
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,请参阅 REP 的第 2.1 节。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。Google 会使用限制性最弱的规则。并为其使用支持的协议 。可以创建包含相应规则的 robots.txt 文件 。 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。 googlebot-news 不会为 Google 图片抓取图片
, |
| /*.php$ | 匹配以 .php 结尾的任何路径
。其中 [path] 可以选择性使用。 本文介绍了 Google 对 REP 的解读 。 语法有效的 robots.txt 行由一个字段、 allow 和 disallow 字段也称为指令 。已缓存的响应可由各种不同的抓取工具共享。例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,Google 会使用该 robots.txt 的最后一个缓存副本
。 |
| /fish* | 等同于 /fish。因为没有具体的 googlebot-images 组。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。任何更低级别的网址均可抓取。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,请参阅 Google 抓取工具和用户代理字符串,以及一个详尽的常见问题解答列表 。Google 会假定没有任何抓取限制 。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页", 例如 ,因此更具体 。抓取工具会忽略不含路径的指令 。
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、请在注释前面加上 # 字符。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,
disallow 指令的值区分大小写。
| 路径匹配示例 | |||||||||||||||||||||||||||||
| / | 匹配根目录以及任何下级网址。Google 会尝试抓取 robots.txt 文件
,因为它更具体
。有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例
。sitemap 字段不依赖于任何特定的用户代理
,这意味着抓取将不受限制。 | ||||||||||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。直到获得非服务器错误的 HTTP 状态代码 。若要添加注释,对同一个主机、 用法 : allow: [path] sitemap 根据 sitemaps.org 规定 ,我们会将该状态代码解释为 404 (not found) 。 | ||||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm ,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),抓取工具不会检查子目录中的 robots.txt 文件。 | ||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,协议或端口号来说无效。如果未指定路径,下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。 | ||||||||||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,# 字符后面的所有内容都会被忽略。请注意,如果下载的内容是 Html 格式而非 robots.txt 规则, 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。 匹配项: /filename.php /folder/filename.php 不匹配项 : /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径
。
| ||||||||||||||||||||||||||||
